<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Scene: Sustainable Princeton + NRG Present - Philly Chit Chat</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://phillychitchat.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Scene: Sustainable Princeton + NRG Present - Philly Chit Chat" />
	<meta property="og:description" content="Sustainable Princeton, in partnership with NRG Energy, will be hosted itselectric vehicle (EV) ride &amp; drive event at eCommuter Fest during NationalDrive Electric Week in late September. The free, one-day community festival celebrates thelatest in carbon-free commuter technology. Sustainable Princeton..." />
	<meta property="og:url" content="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" />
	<meta property="og:site_name" content="Philly Chit Chat" />
	<meta property="article:published_time" content="2022-10-17T15:55:27+00:00" />
	<meta property="article:modified_time" content="2022-10-17T15:55:29+00:00" />
	<meta property="og:image" content="https://phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg" />
	<meta name="author" content="HughE Dillon" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="HughE Dillon" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/","url":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/","name":"Scene: Sustainable Princeton + NRG Present - Philly Chit Chat","isPartOf":{"@id":"https://phillychitchat.com/#website"},"primaryImageOfPage":{"@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#primaryimage"},"image":{"@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#primaryimage"},"thumbnailUrl":"https://phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg","datePublished":"2022-10-17T15:55:27+00:00","dateModified":"2022-10-17T15:55:29+00:00","author":{"@id":"https://phillychitchat.com/#/schema/person/aefbc3c4db192ca820612ff4f93f82eb"},"breadcrumb":{"@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#primaryimage","url":"https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?fit=580%2C387&ssl=1","contentUrl":"https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?fit=580%2C387&ssl=1","width":580,"height":387},{"@type":"BreadcrumbList","@id":"https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://phillychitchat.com/"},{"@type":"ListItem","position":2,"name":"Scene: Sustainable Princeton + NRG Present"}]},{"@type":"WebSite","@id":"https://phillychitchat.com/#website","url":"https://phillychitchat.com/","name":"Philly Chit Chat","description":"","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://phillychitchat.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://phillychitchat.com/#/schema/person/aefbc3c4db192ca820612ff4f93f82eb","name":"HughE Dillon","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://phillychitchat.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/086a5941011c425b1577c5418bfc1c65?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/086a5941011c425b1577c5418bfc1c65?s=96&d=identicon&r=g","caption":"HughE Dillon"},"url":"https://phillychitchat.com/author/hughe181017/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Feed" href="https://phillychitchat.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Comments Feed" href="https://phillychitchat.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Scene: Sustainable Princeton + NRG Present Comments Feed" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/phillychitchat.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='fes-css'  href='https://phillychitchat.com/wp-content/plugins/feedburner-email-subscription/css/styles.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='sbi_styles-css'  href='https://phillychitchat.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=6.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://phillychitchat.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://phillychitchat.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://phillychitchat.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://phillychitchat.com/wp-content/themes/piemont/style.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://phillychitchat.com/wp-content/themes/piemont-child/style.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/bootstrap.css?ver=6.0.3' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='piemont-fonts-css'  href='//fonts.googleapis.com/css?family=Lora%3A400%7CLora%3A400%2C400italic%2C700%2C700italic%7CRoboto%7C&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='owl-main-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.carousel.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='owl-theme-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.theme.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='stylesheet-css'  href='https://phillychitchat.com/wp-content/themes/piemont-child/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://phillychitchat.com/wp-content/themes/piemont/responsive.css?ver=all' type='text/css' media='all' />
<link rel='stylesheet' id='animations-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/animations.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/font-awesome.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='select2-mgt-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/select2/select2.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='offcanvasmenu-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/offcanvasmenu.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='nanoscroller-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/nanoscroller.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='swiper-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/idangerous.swiper.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://c0.wp.com/c/6.0.3/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://phillychitchat.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.5-a.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://phillychitchat.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.5-a.3' type='text/css' media='all' />
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont-child/js/pcc.js?ver=6.0.3' id='piemont-child-js-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0.3/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0.3/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://phillychitchat.com/wp-json/" /><link rel="alternate" type="application/json" href="https://phillychitchat.com/wp-json/wp/v2/posts/91535" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://phillychitchat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://phillychitchat.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9LPPc-nOn' />
<link rel="alternate" type="application/json+oembed" href="https://phillychitchat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://phillychitchat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F&#038;format=xml" />
	<style>img#wpstats{display:none}</style>
		<style type="text/css">
.upcoming-events li {
	margin-bottom: 10px;
}
.upcoming-events li span {
	display: block;
}
</style>
		<link rel="amphtml" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/amp/"><meta name="twitter:partner" content="tfwp" /><link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="32x32" />
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://s0.wp.com/i/webclip.png" />
<meta name="msapplication-TileImage" content="https://s0.wp.com/i/webclip.png" />

<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Scene: Sustainable Princeton + NRG Present" /><meta name="twitter:description" content="NRG EV Business Resource Group Sustainable Princeton, in partnership with NRG Energy, will be hosted itselectric vehicle (EV) ride &amp; drive event at eCommuter Fest during NationalDrive Electric Week in late September. The free, one-day community festival celebrates thelatest in&hellip;" /><meta name="twitter:image" content="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6.jpg?fit=1500%2C1000&amp;ssl=1" />
<!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>
<body class="post-template-default single single-post postid-91535 single-format-standard blog-style-1 blog-slider-enable">



<header>
<div class="container header-logo-center">
  <div class="row">
    <div class="col-md-12">
     
      <div class="header-left">
              </div>
      
      <div class="header-center">
            <div class="logo">
    <a class="logo-link" href="https://phillychitchat.com"><img src="https://phillychitchat.com/wp-content/uploads/2019/02/logo2-2-1.png" alt="Philly Chit Chat"></a>
        </div>
          </div>

      <div class="header-right">
            <ul class="header-nav">
            </ul>
      </div>
    </div>
  </div>
    
</div>

        <div class="mainmenu-belowheader menu_light mainmenu-uppercase mainmenu-normalfont mainmenu-downarrow menu-center">
        <div class="mainmenu-belowheader-spacer"></div>
        <div id="navbar" class="navbar navbar-default clearfix">
          <div class="navbar-inner">
              <div class="container">
             
              <div class="navbar-toggle" data-toggle="collapse" data-target=".collapse">
                Menu              </div>

              <div class="navbar-collapse collapse"><ul id="menu-main-menu-1" class="nav"><li id="menu-item-16" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/about/">Hire Us/About</a></li>
<li id="menu-item-15" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/pccbuzz/">Todays Post</a></li>
<li id="menu-item-14" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/contact/">Contact</a></li>
<li id="menu-item-51874" class=" menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.phillychitchat.com/?s">Search</a></li>
</ul></div>              </div>
          </div>
        </div>
    </div>
        
    </header>


	
<div class="content-block">
<div class="post-container container">
	<div class="row">
					<div class="col-md-3 main-sidebar sidebar">
				<ul id="left-sidebar">
					<li id="blog_subscription-2" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe to PhillyChitChat Be The First To Know</h2>

			<div class="wp-block-jetpack-subscriptions__container">
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
									<p id="subscribe-email">
						<label id="jetpack-subscribe-label"
							class="screen-reader-text"
							for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required"
																					value=""
							id="subscribe-field-blog_subscription-2"
							placeholder="Email Address"
						/>
					</p>

					<p id="subscribe-submit"
											>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="source" value="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="subscribe-blog-blog_subscription-2"/>
												<button type="submit"
															class="wp-block-button__link"
																					name="jetpack_subscriptions_widget"
						>
							Subscribe						</button>
					</p>
							</form>
							<div class="wp-block-jetpack-subscriptions__subscount">
					Join 45,568 other subscribers				</div>
						</div>
			
</li>
<li id="media_image-10" class="widget widget_media_image"><h2 class="widgettitle">AACR Foundation</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://www.aacr.org/"><img width="300" height="178" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?fit=300%2C178&amp;ssl=1" class="image wp-image-88342  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="AACR Foundation" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?w=795&amp;ssl=1 795w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?resize=300%2C178&amp;ssl=1 300w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?resize=768%2C456&amp;ssl=1 768w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?resize=100%2C58&amp;ssl=1 100w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="88342" data-permalink="https://phillychitchat.com/screenshot-2022-03-07-at-13-26-31-aacr-foundations-aacr_foundation-profile-on-instagram-1105-posts-2/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?fit=795%2C472&amp;ssl=1" data-orig-size="795,472" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot 2022-03-07 at 13-26-31 AACR Foundation&#8217;s ( aacr_foundation) profile on Instagram • 1,105 posts" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?fit=300%2C178&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-26-31-AACR-Foundations-aacr_foundation-profile-on-Instagram-•-1105-posts-2.png?fit=795%2C472&amp;ssl=1" /></a></li>
<li id="media_image-19" class="widget widget_media_image"><h2 class="widgettitle">Rivers Casino Philadelphia</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://www.riverscasino.com/philadelphia/"><img width="200" height="125" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-12-05-Blog-Post-Content-Rivers-Philly-St-Patricks-Weekend-hughe-phillychitchat-com-Philly...-Ad.png?fit=200%2C125&amp;ssl=1" class="image wp-image-88337  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="88337" data-permalink="https://phillychitchat.com/screenshot-2022-03-07-at-13-12-05-blog-post-content-rivers-philly-st-patricks-weekend-hughe-phillychitchat-com-philly-ad/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-12-05-Blog-Post-Content-Rivers-Philly-St-Patricks-Weekend-hughe-phillychitchat-com-Philly...-Ad.png?fit=200%2C125&amp;ssl=1" data-orig-size="200,125" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot-2022-03-07-at-13-12-05-Blog-Post-Content-Rivers-Philly-St-Patricks-Weekend-hughe-phillychitchat-com-Philly&#8230;-Ad" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-12-05-Blog-Post-Content-Rivers-Philly-St-Patricks-Weekend-hughe-phillychitchat-com-Philly...-Ad.png?fit=200%2C125&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/03/Screenshot-2022-03-07-at-13-12-05-Blog-Post-Content-Rivers-Philly-St-Patricks-Weekend-hughe-phillychitchat-com-Philly...-Ad.png?fit=200%2C125&amp;ssl=1" /></a></li>
<li id="media_image-22" class="widget widget_media_image"><h2 class="widgettitle">Louie Louie</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 210px" class="wp-caption alignnone"><a href="https://www.louielouie.restaurant/"><img width="200" height="160" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/04/Screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-Google-Search-Ad.png?fit=200%2C160&amp;ssl=1" class="image wp-image-89010  attachment-full size-full" alt="Louie Louie" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="89010" data-permalink="https://phillychitchat.com/screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-google-search-ad/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/04/Screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-Google-Search-Ad.png?fit=200%2C160&amp;ssl=1" data-orig-size="200,160" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-Google-Search-Ad" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/04/Screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-Google-Search-Ad.png?fit=200%2C160&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/04/Screenshot-2022-04-15-at-10-14-02-louielouie-restaurant-Google-Search-Ad.png?fit=200%2C160&amp;ssl=1" /></a><p class="wp-caption-text">Louie Louie  70’s style French inspired Bistro
3611 WALNUT STREET </p></div></li>
<li id="block-5" class="widget widget_block widget_media_image"><div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><a href="https://www.visitphilly.com/"><img loading="lazy" src="https://phillychitchat.com/wp-content/uploads/2022/10/Screenshot-2022-10-12-at-11-21-13-visit-philadelphia-Google-Search.png" alt="" class="wp-image-91486" width="275" height="138" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/Screenshot-2022-10-12-at-11-21-13-visit-philadelphia-Google-Search.png?w=568&amp;ssl=1 568w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/Screenshot-2022-10-12-at-11-21-13-visit-philadelphia-Google-Search.png?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 275px) 100vw, 275px" /></a><figcaption><a rel="noreferrer noopener" href="https://www.visitphilly.com/" target="_blank">Official Philly Tourism and Visitor Information</a></figcaption></figure></div></li>
				</ul>
			</div>
				<div class="col-md-6">
			<div class="blog-post blog-post-single clearfix">
				<article id="post-91535" class="post-91535 post type-post status-publish format-standard hentry category-uncategorized">
							<div class="post-content-wrapper">

								<div class="post-content">
																		
									<div class="post-categories"><a href="https://phillychitchat.com/category/uncategorized/" rel="category tag">Uncategorized</a></div>

									
									<h1 class="entry-title post-header-title">Scene: Sustainable Princeton + NRG Present</h1>
									<div class="post-info clearfix">
										<span>October 17, 2022</span>
																														<span>by HughE Dillon</span>
										
																														<span class="comments-count"><a href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/#respond">Leave a comment</a></span>
										
										
									</div>
																																																								<div class="entry-content">
										<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91538" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_456a6-1/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;20&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664556827&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;32&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_456a6-1" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?fit=580%2C387&amp;ssl=1" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91538" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_456a6-1.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption>NRG EV Business Resource Group</figcaption></figure></div>


<p>Sustainable Princeton, in partnership with<strong><a href="https://www.nrg.com/" target="_blank" rel="noreferrer noopener"> NRG Energy</a></strong>, will be hosted its<br>electric vehicle (EV) ride &amp; drive event at eCommuter Fest during National<br>Drive Electric Week in late September. The free, one-day community festival celebrates the<br>latest in carbon-free commuter technology.</p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91541" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4422/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;18&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664554509&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;1250&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4422" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91541" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4422.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p><strong><a href="https://www.sustainableprinceton.org/" target="_blank" rel="noreferrer noopener">Sustainable Princeton</a></strong> is a nonprofit organization whose mission is to inspire<br>the community to develop and implement solutions that positively impact the<br>environment. NRG, as the event partner, will be featuring newly branded EV<br>chargers and have representatives available to discuss NRG EV charging plans<br>for customers.</p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91545" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4708/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664561087&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;170&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.008&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4708" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91545" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4708.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p>Princeton High School Bike Club (PHS Bike Club) was on hand offering free, light bike repairs including: pumping tires, minor brake adjustments, changing seat heights, and applying lubricant to brakes, chains, derailers, and shifters. <br>PHS Bike Club will also be collecting old bikes to refurbish and give to Princeton’s underserved population. </p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91546" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4451/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;14&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664555146&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4451" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91546" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4451.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p>There were also vendors on hand like this cute flower shop, an ice cream stand and food trucks as well. </p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91548" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4491/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;14&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664555775&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;100&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4491" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91548" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4491.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption>Jeanie Davey, Communications Specialist at NRG Energy welcomes guests to Sustainable Princeton</figcaption></figure></div>

<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91558" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4603/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;20&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664557991&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4603" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91558" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4603.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption>A couple stands in front of their electric car.  Folks from the local electric car community brought their cars to the event, sharing stories of ownership.</figcaption></figure></div>


<p>Representatives from <a href="https://www.picknrg.com/" target="_blank" rel="noreferrer noopener">NRG Energy, Inc.</a>, were onsite providing information on energy-related products and services that support a sustainable lifestyle, including NRG Carbon Offsets and renewable electricity plans. NRG Carbon Offsets, in particular, are an exciting new addition to NRG’s suite of solutions. Through NRG Carbon Offsets, a customer reduces the net carbon emissions of daily activities such as driving, traveling, or using electricity in the home. An NRG Carbon Offset subscription or one-time purchase lowers an individual’s carbon footprint by investing in third-party verified carbon reduction projects.</p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91551" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4419-1/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;18&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664554442&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1250&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4419-1" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91551" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4419-1.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>

<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91553" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4433/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;14&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664554727&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1250&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4433" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91553" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4433.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p>Managing your home’s energy—and the rewards you earn from using it is easier with the newly redesigned My NRG app. Download it today to track your, rewards, view your plan details, manage your account, monitor usage, and more. Get started at <strong><a href="http://picknrg.com/MyNRGApp" target="_blank" rel="noreferrer noopener">picknrg.com/MyNRGApp</a></strong><br>.</p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91554" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4666-2/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664560401&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;38&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4666" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91554" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4666.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption>Robert Gibbs, NRG <a href="https://www.linkedin.com/company/7136/"></a><br>Director &#8211; Corporate and Regulatory Affairs takes the Ford Lighting our for a spin.</figcaption></figure></div>

<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91556" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4470/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;14&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664555488&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4470" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91556" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4470.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption>Princeton Mayor <strong>Mark Freda </strong>came out to support Sustainable Princeton.</figcaption></figure></div>

<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91559" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4548/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;20&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664556561&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;150&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4548" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91559" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4548.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p>The third time covering Sustainable Princeton event, and I learned a lot. The technology has really advanced with each year, as has the turn out as people are interested in sustainable living. </p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91562" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4688/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?fit=580%2C394&amp;ssl=1" data-orig-size="580,394" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664560950&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;112&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4688" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?fit=300%2C204&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?fit=580%2C394&amp;ssl=1" loading="lazy" width="580" height="394" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?resize=580%2C394&#038;ssl=1" alt="" class="wp-image-91562" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4688.jpg?resize=300%2C204&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /><figcaption><a href="https://www.instagram.com/pick_nrg/"></a><br>Now that cooler weather is moving in, it’s the perfect time to make sure your home is properly insulated. Not only will it help keep the heat in (and the ghosts out), it can reduce your energy costs, too. Find our insulation tips at <strong><a href="http://picknrg.com/Insulate" target="_blank" rel="noreferrer noopener">picknrg.com/Insulate</a></strong></figcaption></figure></div>

<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-attachment-id="91569" data-permalink="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/dsc_4660/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?fit=580%2C387&amp;ssl=1" data-orig-size="580,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;20&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1664559976&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;122&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.05&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DSC_4660" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?fit=580%2C387&amp;ssl=1" loading="lazy" width="580" height="387" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?resize=580%2C387&#038;ssl=1" alt="" class="wp-image-91569" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?w=580&amp;ssl=1 580w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2022/10/DSC_4660.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 580px) 100vw, 580px" data-recalc-dims="1" /></figure></div>


<p>Ready for winter? Prepare your business for the climate and market challenges of the season by attending our Winter Market Outlook Webinar, hosted by NRG industry experts. <a href="http://ms.spr.ly/6185duJul?fbclid=IwAR0R-WfoiObjjFRElwuM315fupj3JNccaINBjbBIMhJPdX4g0bb8G82oNAQ" target="_blank" rel="noreferrer noopener">http://ms.spr.ly/6185duJul</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-91535" class="share-twitter sd-button share-icon" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-91535" class="share-facebook sd-button share-icon" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-144387658-91535-634e5d5dd1d73' data-src='https://widgets.wp.com/likes/#blog_id=144387658&amp;post_id=91535&amp;origin=phillychitchat.com&amp;obj_id=144387658-91535-634e5d5dd1d73' data-name='like-post-frame-144387658-91535-634e5d5dd1d73' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>																			</div><!-- .entry-content -->


																		</div>

							</div>

				
				
									<div class="post-social-wrapper">
	<div class="post-social-title show-social-share">
		<a><i class="fa fa-share-alt"></i> Share</a>
	</div>
	<div class="post-social">
		<a title="Share this" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" data-title="Scene: Sustainable Princeton + NRG Present" class="facebook-share"> <i class="fa fa-facebook"></i></a>
		<a title="Tweet this" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" data-title="Scene: Sustainable Princeton + NRG Present" class="twitter-share"> <i class="fa fa-twitter"></i></a>
		<a title="Share with Google Plus" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" data-title="Scene: Sustainable Princeton + NRG Present" class="googleplus-share"> <i class="fa fa-google-plus"></i></a>
		<a title="Pin this" href="https://phillychitchat.com/2022/10/17/scene-sustainable-princeton-nrg-present/" data-title="Scene: Sustainable Princeton + NRG Present" data-image="" class="pinterest-share"> <i class="fa fa-pinterest"></i></a>
	</div>
	<div class="clear"></div>
</div>				


				</article>


			</div>

										
				<nav role="navigation" id="nav-below" class="navigation-post navigation-paging">
	
		<div class="container-fluid">
	<div class="row">
		<div class="col-md-12">
		<div class="nav-previous"><a href="https://phillychitchat.com/2022/10/14/saturday-brauhaus-schmitz-south-street-oktoberfest-10-15-22/" rel="prev">Previous post</a></div>		
				</div>
	</div>
	</div>
	
	</nav><!-- #nav-below -->
	
									
				<div id="comments" class="comments-area">

	
					<div class="comments-form-wrapper" id="comments-form-wrapper">
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/10/17/scene-sustainable-princeton-nrg-present/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&#038;postid=91535&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=77b65ae3bd&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.5-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=bf4631c13d20fe9df4552677c5d24a3d6a5b634b#parent=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

				</div>
				
	
	

</div><!-- #comments -->



		</div>
				<div class="col-md-3 main-sidebar sidebar">
		<ul id="main-sidebar">
		  <li id="text-2" class="widget widget_text"><h2 class="widgettitle">About Philly Chit Chat</h2>
			<div class="textwidget"><p><img loading="lazy" class="alignnone size-thumbnail wp-image-71008" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/03/Headshot.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><br />
HughE Dillon, LLC<br />
Hired Publicity Photographer for media placements. See About for Info to Book Us.</p>
</div>
		</li>
<li id="block-3" class="widget widget_block widget_media_image"><div class="wp-block-image">
<figure class="aligncenter size-full"><img loading="lazy" width="200" height="131" src="https://phillychitchat.com/wp-content/uploads/2022/09/Screenshot-2022-09-07-at-00-48-43-Copy-for-your-blog-hughe@phillychitchat.com-PhillyChitChat-Mail-Ad.png" alt="" class="wp-image-90935"/><figcaption><strong><a rel="noreferrer noopener" href="https://www.vibevaultfit.com/" target="_blank">Vibe Vault Fit</a></strong><br>Gym/Physical Fitness Center</figcaption></figure></div></li>
<li id="block-2" class="widget widget_block">
<h2 class="has-text-align-center">Advertise With Us</h2>
</li>
<li id="block-4" class="widget widget_block widget_media_image"><div class="wp-block-image">
<figure class="aligncenter size-full"><a href="https://linktr.ee/thegroundcpg"><img loading="lazy" width="192" height="200" src="https://phillychitchat.com/wp-content/uploads/2022/07/Screenshot-2022-07-14-at-16-42-24-The-Ground-CPG-☕️🪴🎁-@thegroundcpg-•-Instagram-photos-and-videos-Ad.png" alt="" class="wp-image-90388"/></a><figcaption>The Ground CPG at The Gotham<br><br>Philly's Newest Coffee Shop &amp; Plant Store</figcaption></figure></div></li>
<li id="media_image-16" class="widget widget_media_image"><h2 class="widgettitle">Teal Butterfly Ovarian Cancer Awareness</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 210px" class="wp-caption alignnone"><a href="https://www.tealbutterfly.org/"><img width="200" height="200" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?fit=200%2C200&amp;ssl=1" class="image wp-image-78522  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?w=200&amp;ssl=1 200w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="78522" data-permalink="https://phillychitchat.com/screenshot_2020-08-11-teal-butterfly-challenge-home-page-custom/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?fit=200%2C200&amp;ssl=1" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-08-11 Teal Butterfly Challenge &#8211; Home Page (Custom)" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?fit=200%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/08/Screenshot_2020-08-11-Teal-Butterfly-Challenge-Home-Page-Custom.png?fit=200%2C200&amp;ssl=1" /></a><p class="wp-caption-text">Teal Butterfly is a non-profit 501(c)(3) organization whose mission is to raise awareness about the early signs and symptoms of ovarian cancer by educating the public through community events and social media campaigns</p></div></li>
<li id="text-16" class="widget widget_text"><h2 class="widgettitle">The Kimmel Cultural Campus</h2>
			<div class="textwidget"><p><img loading="lazy" class="size-thumbnail wp-image-70803 aligncenter" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/03/me-Custom.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><a href="https://www.kimmelcenter.org/">Kimmel Cultural Campus</a> &#8211;</p>
</div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><h2 class="widgettitle">Follow On Social Media</h2>
<div class="textwidget custom-html-widget"><div class="social-icons-wrapper"><a href="https://www.facebook.com/PhillyChitChat/" target="_blank" class="a-facebook" title="Facebook" rel="noopener"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/HughE_Dillon" target="_blank" class="a-twitter" title="Twitter" rel="noopener"><i class="fa fa-twitter"></i></a><a href="https://plus.google.com/+HughEDillon" target="_blank" class="a-google-plus" title="Google+" rel="noopener"><i class="fa fa-google-plus"></i></a><a href="https://www.instagram.com/phillychitchat/" target="_blank" class="a-instagram" title="Instagram" rel="noopener"><i class="fa fa-instagram"></i></a><a href="https://www.periscope.tv/iphillychitchat" target="_blank" class="a-periscope" title="Periscope" rel="noopener"><i class="fa fa-map-marker"></i></a></div></div></li>
<li id="twitter-follow-2" class="widget widget_twitter-follow"><h2 class="widgettitle">#SaveTheDatePHL</h2>
<div class="twitter-follow"><a href="https://twitter.com/intent/follow?screen_name=HughE_Dillon" class="twitter-follow-button" data-show-screen-name="false">Follow @HughE_Dillon</a></div></li>
<li id="media_image-12" class="widget widget_media_image"><h2 class="widgettitle">Freeman Interiors</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 160px" class="wp-caption alignnone"><a href="http://www.freemaninteriors.com/"><img width="150" height="150" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?resize=150%2C150&amp;ssl=1" class="image wp-image-80916  attachment-thumbnail size-thumbnail" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="80916" data-permalink="https://phillychitchat.com/chit-chat-ad-1-7-211/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?fit=3336%2C3456&amp;ssl=1" data-orig-size="3336,3456" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Chit Chat Ad 1.7.21(1)" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?fit=290%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2021/01/Chit-Chat-Ad-1.7.211.jpg?fit=810%2C840&amp;ssl=1" /></a><p class="wp-caption-text">Freeman Interiors is an award winning full-service interior design firm</p></div></li>
<li id="upcoming_events_widget-2" class="widget widget_upcoming_events_widget"><h2 class="widgettitle">Upcoming Events</h2>
			<p>No upcoming events</p>
			</li>
<li id="categories-2" class="widget widget_categories"><h2 class="widgettitle">Categories</h2>

			<ul>
					<li class="cat-item cat-item-6126"><a href="https://phillychitchat.com/category/around-town-with-hughe/">Around Town With HughE</a>
</li>
	<li class="cat-item cat-item-2205"><a href="https://phillychitchat.com/category/awesome/">awesome</a>
</li>
	<li class="cat-item cat-item-6038"><a href="https://phillychitchat.com/category/celebrities-in-philly/">Celebrities in Philly</a>
</li>
	<li class="cat-item cat-item-6066"><a href="https://phillychitchat.com/category/charity/">Charity</a>
</li>
	<li class="cat-item cat-item-6067"><a href="https://phillychitchat.com/category/charity-gala/">Charity Gala</a>
</li>
	<li class="cat-item cat-item-2206"><a href="https://phillychitchat.com/category/cool/">cool</a>
</li>
	<li class="cat-item cat-item-6035"><a href="https://phillychitchat.com/category/main-line-today/">Main Line Today</a>
</li>
	<li class="cat-item cat-item-2212"><a href="https://phillychitchat.com/category/philadelphia/">Philadelphia</a>
</li>
	<li class="cat-item cat-item-6189"><a href="https://phillychitchat.com/category/philly-scene/">Philly Scene</a>
</li>
	<li class="cat-item cat-item-6157"><a href="https://phillychitchat.com/category/uncategorized/philly-to-do-uncategorized/">Philly To Do</a>
</li>
	<li class="cat-item cat-item-6029"><a href="https://phillychitchat.com/category/philly-to-do/">Philly To Do</a>
</li>
	<li class="cat-item cat-item-6048"><a href="https://phillychitchat.com/category/philadelphia/real-estate/">Real Estate</a>
</li>
	<li class="cat-item cat-item-6198"><a href="https://phillychitchat.com/category/south-jersey/">South Jersey</a>
</li>
	<li class="cat-item cat-item-6135"><a href="https://phillychitchat.com/category/uncategorized/sponsored-post/">Sponsored Post</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://phillychitchat.com/category/uncategorized/">Uncategorized</a>
</li>
			</ul>

			</li>
		</ul>
		</div>
			</div>
	</div>
</div>




<div class="footer-instagram-wrapper"><h5>Follow us @ Instagram</h5>		<div id="sbi_mod_error" >
			<span>This error message is only visible to WordPress admins</span><br />
			<p><strong>Error: No feed found.</strong>
			<p>Please go to the Instagram Feed settings page to create a feed.</p>
		</div>
		</div><div class="container-fluid container-fluid-footer">
  <div class="row">
        <div class="footer-sidebar-2-wrapper">
      <div class="footer-sidebar-2 sidebar container footer-container">
      
        <ul id="footer-sidebar-2" class="clearfix">
          <li id="feedburner-email-subscription-2" class="widget feedburner-email-subscription"><h2 class="widgettitle">Subscribe</h2>
<form class="fes fes-default" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open( 'http://feedburner.google.com/fb/a/mailverify?uri=PhillyChitChat', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" ><div class="form-group"><label class="sr-only"><span class="screen-reader-text">Email Subscription</span></label><input class="form-control search-field" type="text" value="Enter Your Email" onfocus="if(this.value=='Enter Your Email')this.value='';" onblur="if(this.value=='')this.value='Enter Your Email'" name="email" /></div><button type="submit" class="btn btn-default btn-submit">Submit</button><input type="hidden" value="PhillyChitChat" name="uri" /><input type="hidden" name="loc" value="en_US" /></form></li>
        </ul>
      
      </div>
    </div>
            <footer class="footer-style-mini">
      <div class="container">
      <div class="row">
                    <div class="col-md-12 footer-logo">
            <a class="logo-link" href="https://phillychitchat.com"><img src="http://www.phillychitchat.com/wp-content/uploads/2016/04/logo2-1.png" alt="Philly Chit Chat" /></a>          </div>
                    <div class="col-md-6 footer-menu">
            <div class="menu-main-menu-container"><ul id="menu-main-menu-2" class="footer-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="https://phillychitchat.com/about/">Hire Us/About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://phillychitchat.com/pccbuzz/">Todays Post</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://phillychitchat.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51874"><a href="http://www.phillychitchat.com/?s">Search</a></li>
</ul></div>          </div>
          <div class="col-md-6 copyright">
               <p style="text-align: center">© 2019 Philly Chit Chat</p>          </div>
                </div>
      </div>
      <a id="top-link" href="#top"></a>
    </footer>

  </div>
</div>

<!--  -->
<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic"  src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202242"></script>
<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://phillychitchat.com/wp-admin/admin-ajax.php";
</script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/phillychitchat.com\/2022\/10\/17\/scene-sustainable-princeton-nrg-present\/":91535};
	</script>
				<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.6.3' id='swv-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/phillychitchat.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.3' id='contact-form-7-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/phillychitchat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0.3/wp-includes/js/thickbox/thickbox.js' id='thickbox-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/bootstrap.min.js?ver=3.1.1' id='piemont-bootstrap-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/easing.js?ver=1.3' id='piemont-easing-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/select2/select2.min.js?ver=3.5.1' id='piemont-select2-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.carousel.min.js?ver=1.3.3' id='owl-carousel-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/jquery.nanoscroller.min.js?ver=3.4.0' id='nanoscroller-js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/template.js?ver=1.0' id='piemont-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='twitter-wjs-js-extra'>
/* <![CDATA[ */
window.twttr=(function(w){t=w.twttr||{};t._e=[];t.ready=function(f){t._e.push(f);};return t;}(window));
/* ]]> */
</script>
<script type="text/javascript" id="twitter-wjs" async defer src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=11.5-a.3' id='jetpack_likes_queuehandler-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/phillychitchat.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/phillychitchat.com\/wp-admin\/admin-ajax.php","nonce":"a6915d483d","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/phillychitchat.com\/wp-login.php?redirect_to=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=11.5-a.3' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1664378836' id='akismet-frontend-js'></script>
<script type='text/javascript' id='sbi_scripts-js-extra'>
/* <![CDATA[ */
var sb_instagram_js_options = {"font_method":"svg","resized_url":"https:\/\/phillychitchat.com\/wp-content\/uploads\/sb-instagram-feed-images\/","placeholder":"https:\/\/phillychitchat.com\/wp-content\/plugins\/instagram-feed\/img\/placeholder.png","ajax_url":"https:\/\/phillychitchat.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/instagram-feed/js/sbi-scripts.min.js?ver=6.0.8' id='sbi_scripts-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.5-a.3' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202242#ver=202242' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&postid=91535&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=77b65ae3bd&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=bf4631c13d20fe9df4552677c5d24a3d6a5b634b#parent=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&postid=91535&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=77b65ae3bd&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=bf4631c13d20fe9df4552677c5d24a3d6a5b634b#parent=https%3A%2F%2Fphillychitchat.com%2F2022%2F10%2F17%2Fscene-sustainable-princeton-nrg-present%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

			<script src='https://stats.wp.com/e-202242.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'144387658',post:'91535',tz:'-4',srv:'phillychitchat.com',hp:'atomic',ac:'2',amp:'0',j:'1:11.5-a.3'} ]);
		_stq.push([ 'clickTrackerInit', '144387658', '91535' ]);
	</script></body>
</html>
<!--
	generated in 0.273 seconds
	101949 bytes batcached for 300 seconds
-->
