<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Today: Dim Sum House&#039;s Grand Opening in Rittenhouse With Free Food - Philly Chit Chat</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://phillychitchat.com/xmlrpc.php" />

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Today: Dim Sum House&#039;s Grand Opening in Rittenhouse With Free Food - Philly Chit Chat" />
<meta property="og:description" content="Today: Dim Sum House&#8216;s Grand Opening in Rittenhouse With Free Food. Jane Guo (above) and Jackson Fu announce the grand opening of Dim Sum House by Jane G’s TODAY February 20, 2020, at 1930 Chestnut Street, at 11:30am. The mother-son..." />
<meta property="og:url" content="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" />
<meta property="og:site_name" content="Philly Chit Chat" />
<meta property="article:tag" content="aversa pr" />
<meta property="article:tag" content="Chinese Food Center City" />
<meta property="article:tag" content="client" />
<meta property="article:tag" content="Dim Sum House" />
<meta property="article:tag" content="Media and Influencer Night" />
<meta property="article:section" content="Uncategorized" />
<meta property="article:published_time" content="2020-02-20T07:52:10+00:00" />
<meta property="og:image" content="https://phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg" />
<meta property="og:image:secure_url" content="https://phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Today: Dim Sum House&#8216;s Grand Opening in Rittenhouse With Free Food. Jane Guo (above) and Jackson Fu announce the grand opening of Dim Sum House by Jane G’s TODAY February 20, 2020, at 1930 Chestnut Street, at 11:30am. The mother-son..." />
<meta name="twitter:title" content="Today: Dim Sum House&#039;s Grand Opening in Rittenhouse With Free Food - Philly Chit Chat" />
<meta name="twitter:image" content="https://phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://phillychitchat.com/#website","url":"https://phillychitchat.com/","name":"Philly Chit Chat","inLanguage":"en-US","potentialAction":{"@type":"SearchAction","target":"https://phillychitchat.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?fit=550%2C367&ssl=1","width":550,"height":367},{"@type":"WebPage","@id":"https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/#webpage","url":"https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/","name":"Today: Dim Sum House&#039;s Grand Opening in Rittenhouse With Free Food - Philly Chit Chat","isPartOf":{"@id":"https://phillychitchat.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/#primaryimage"},"datePublished":"2020-02-20T07:52:10+00:00","dateModified":"2020-02-20T07:52:10+00:00","author":{"@id":"https://phillychitchat.com/#/schema/person/aefbc3c4db192ca820612ff4f93f82eb"}},{"@type":["Person"],"@id":"https://phillychitchat.com/#/schema/person/aefbc3c4db192ca820612ff4f93f82eb","name":"HughE Dillon","image":{"@type":"ImageObject","@id":"https://phillychitchat.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/086a5941011c425b1577c5418bfc1c65?s=96&d=identicon&r=g","caption":"HughE Dillon"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Feed" href="https://phillychitchat.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Comments Feed" href="https://phillychitchat.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Philly Chit Chat &raquo; Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food Comments Feed" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/phillychitchat.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='fes-css'  href='https://phillychitchat.com/wp-content/plugins/feedburner-email-subscription/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://phillychitchat.com/wp-content/plugins/instagram-feed/css/sb-instagram-2-2.min.css?ver=2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://phillychitchat.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://phillychitchat.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://phillychitchat.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://phillychitchat.com/wp-content/themes/piemont/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://phillychitchat.com/wp-content/themes/piemont-child/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/bootstrap.css?ver=5.3.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='piemont-fonts-css'  href='//fonts.googleapis.com/css?family=Lora%3A400%7CLora%3A400%2C400italic%2C700%2C700italic%7CRoboto%7C&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='owl-main-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.carousel.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='owl-theme-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.theme.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='stylesheet-css'  href='https://phillychitchat.com/wp-content/themes/piemont-child/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://phillychitchat.com/wp-content/themes/piemont/responsive.css?ver=all' type='text/css' media='all' />
<link rel='stylesheet' id='animations-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/animations.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/font-awesome.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='select2-mgt-css'  href='https://phillychitchat.com/wp-content/themes/piemont/js/select2/select2.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='offcanvasmenu-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/offcanvasmenu.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='nanoscroller-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/nanoscroller.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='swiper-css'  href='https://phillychitchat.com/wp-content/themes/piemont/css/idangerous.swiper.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.2.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.2.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont-child/js/pcc.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://phillychitchat.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://phillychitchat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://phillychitchat.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9LPPc-jKu' />
<link rel="alternate" type="application/json+oembed" href="https://phillychitchat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://phillychitchat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="amphtml" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/amp/"><meta name="twitter:partner" content="tfwp" /><link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="32x32" />
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<meta name="msapplication-TileImage" content="https://s0.wp.com/i/webclip.png" />

<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food" /><meta name="twitter:description" content="Today: Dim Sum House&#039;s Grand Opening in Rittenhouse With Free Food. Jane Guo (above) and Jackson Fu announce the grand opening of Dim Sum House by Jane G’s TODAY February 20, 2020, at 1930 Chestnut Street, at 11:30am. The mother-son&hellip;" /><meta name="twitter:image" content="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" />
</head>
<body class="post-template-default single single-post postid-75918 single-format-standard blog-style-1 blog-slider-enable">



<header>
<div class="container header-logo-center">
  <div class="row">
    <div class="col-md-12">
     
      <div class="header-left">
              </div>
      
      <div class="header-center">
            <div class="logo">
    <a class="logo-link" href="https://phillychitchat.com"><img src="https://phillychitchat.com/wp-content/uploads/2019/02/logo2-2-1.png" alt="Philly Chit Chat"></a>
        </div>
          </div>

      <div class="header-right">
            <ul class="header-nav">
            </ul>
      </div>
    </div>
  </div>
    
</div>

        <div class="mainmenu-belowheader menu_light mainmenu-uppercase mainmenu-normalfont mainmenu-downarrow menu-center">
        <div class="mainmenu-belowheader-spacer"></div>
        <div id="navbar" class="navbar navbar-default clearfix">
          <div class="navbar-inner">
              <div class="container">
             
              <div class="navbar-toggle" data-toggle="collapse" data-target=".collapse">
                Menu              </div>

              <div class="navbar-collapse collapse"><ul id="menu-main-menu-1" class="nav"><li id="menu-item-16" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/about/">About</a></li>
<li id="menu-item-15" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/pccbuzz/">#PCCBUZZ</a></li>
<li id="menu-item-14" class=" menu-item menu-item-type-post_type menu-item-object-page"><a href="https://phillychitchat.com/contact/">Contact</a></li>
<li id="menu-item-51874" class=" menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.phillychitchat.com/?s">Search</a></li>
</ul></div>              </div>
          </div>
        </div>
    </div>
        
    </header>


	
<div class="content-block">
<div class="post-container container">
	<div class="row">
					<div class="col-md-3 main-sidebar sidebar">
				<ul id="left-sidebar">
					<li id="blog_subscription-2" class="widget widget_blog_subscription jetpack_subscription_widget"><h2 class="widgettitle">Subscribe To ChitChat</h2>

            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-2">
							Email Address                        </label>
                        <input type="email" name="email" required="required" class="required"
                               value=""
                               id="subscribe-field-blog_subscription-2"
                               placeholder="Email Address"/>
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</li>
<li id="media_image-10" class="widget widget_media_image"><h2 class="widgettitle">Maloumian Oriental Rugs For Sale</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://roysrugs.com/"><img width="600" height="600" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?fit=600%2C600&amp;ssl=1" class="image wp-image-75862  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="Maloumian Oriental Rugs" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?w=600&amp;ssl=1 600w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 600px) 100vw, 600px" data-attachment-id="75862" data-permalink="https://phillychitchat.com/roy-maloumian-ad-2-1/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?fit=600%2C600&amp;ssl=1" data-orig-size="600,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Roy-Maloumian-ad-2-1" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Roy-Maloumian-ad-2-1.jpg?fit=600%2C600&amp;ssl=1" /></a></li>
<li id="text-11" class="widget widget_text"><h2 class="widgettitle">Pinefish Restaurant &#8211; 1138 Pine St</h2>
			<div class="textwidget"><p><img class="size-thumbnail wp-image-71309 aligncenter" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/03/Pinefish-Custom-1.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><a href="https://www.pinefish.fish/">Pinefish</a> – This seafood specialist offers a raw bar, lobsters, steaks, happy-hour oysters &amp; a full bar. <span class="LrzXr">1138 Pine St.</p>
<p></span></p>
</div>
		</li>
<li id="media_image-5" class="widget widget_media_image"><h2 class="widgettitle">Maria Quattrone Real Estate Experts</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 178px" class="wp-caption alignnone"><a href="https://www.liveloveathome.com/"><img width="168" height="225" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/08/New-MQ-Headshot-Custom.jpg?fit=168%2C225&amp;ssl=1" class="image wp-image-73390  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="730 Fitzwater St. Home For Sale" data-attachment-id="73390" data-permalink="https://phillychitchat.com/new-mq-headshot-custom-2/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/08/New-MQ-Headshot-Custom.jpg?fit=168%2C225&amp;ssl=1" data-orig-size="168,225" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;10&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark II&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1421846091&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;75&quot;,&quot;iso&quot;:&quot;160&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="New MQ Headshot (Custom)" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/08/New-MQ-Headshot-Custom.jpg?fit=168%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/08/New-MQ-Headshot-Custom.jpg?fit=168%2C225&amp;ssl=1" /></a><p class="wp-caption-text">RE/MAX @ HOME
Maria Quattrone Real Estate Experts
2054 South Street
Philadelphia, PA 19146
Email:mquattrone@liveloveathome.com
Office: 215.607.3535
www.liveloveathome.com</p></div></li>
<li id="text-4" class="widget widget_text"><h2 class="widgettitle">Parx Casino Near Philadelphia</h2>
			<div class="textwidget"><p><strong><img class="aligncenter wp-image-72286 size-full" src="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/05/Parx-Casino®-_-About-Mozilla-Firefox-2019-05-31-16.06.22-Custom.jpg?resize=200%2C142&#038;ssl=1" alt="" width="200" height="142" data-recalc-dims="1" /><a href="https://www.parxcasino.com/bensalem/">Parx Casino</a> and Racing is a thoroughbred horse racing venue with the largest casino gaming complex in Pennsylvania, and entertainment center.<br />
<span class="b_address">3001 St Rd, Bensalem, PA 19020</span><br />
</strong></p>
</div>
		</li>
<li id="text-22" class="widget widget_text"><h2 class="widgettitle">Freeman Interiors (215) 772-9406</h2>
			<div class="textwidget"><p>&nbsp;</p>
<p><b><u><span class="il"><img class="alignnone size-full wp-image-74777" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/12/Screenshot_2019-12-03-PCC-ad-hughe-phillychitchat-com-PhillyChitChat-Mail-Custom.png?resize=241%2C250&#038;ssl=1" alt="interior design" width="241" height="250" data-recalc-dims="1" /><br />
</span></u></b><a href="https://www.freemaninteriors.com/"><strong>Freeman Interiors</strong> </a>is an award winning Interior Design firm that emphasizes quality &amp; detail in all phases of design from space planning, to design-build and accessories. This full service design firm will take you from “concept” to “completion”. Residential, Hospitality &amp; the Corporate Industry are their clients. <strong>#freeman_interiors<br />
1520 Spruce Street • Philadelphia, PA 19102 </strong><b><u></u></b><b><u></u></b></p>
</div>
		</li>
<li id="media_image-2" class="widget widget_media_image"><h2 class="widgettitle">Richard Sandoval&#8217;s Aqimero at the Ritz Carlton</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 210px" class="wp-caption alignnone"><a href="https://www.aqimero.com/"><img width="200" height="116" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?fit=200%2C116&amp;ssl=1" class="image wp-image-62118  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?w=200&amp;ssl=1 200w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?resize=100%2C58&amp;ssl=1 100w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="62118" data-permalink="https://phillychitchat.com/9-7-2017-9-40-43-am-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?fit=200%2C116&amp;ssl=1" data-orig-size="200,116" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="9-7-2017 9-40-43 AM (Custom)" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?fit=200%2C116&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2017/09/9-7-2017-9-40-43-AM-Custom.jpg?fit=200%2C116&amp;ssl=1" /></a><p class="wp-caption-text">Our kitchen features Latin inspired notes that enhance the tastes of an eclectic menu, while a stunning atmosphere encourages guest-to-guest connections over shareable plates and carefully crafted cocktails.
10 Avenue of the Arts | Philadelphia, Pennsylvania 19102 | 215.523.8200</p></div></li>
<li id="text-6" class="widget widget_text"><h2 class="widgettitle">Replica Creative design + print In Center City</h2>
			<div class="textwidget"><p><img class="alignnone size-thumbnail wp-image-71081" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2019/03/Philly-Chit-Chat-Mozilla-Firefox-2019-03-15-17.56.00.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><br />
<a href="http://replicacreative.com/#replica">Replica CreativeDesign, Print, Copy, Plus so much more </a><br />
<strong>Keith Leaphart</strong><br />
33 South 18th Street<br />
Philadelphia PA 19103<br />
USA</p>
</div>
		</li>
<li id="text-15" class="widget widget_text"><h2 class="widgettitle">PhillyChitChat News</h2>
			<div class="textwidget"><p><strong>Advertise With PhillyChitChat</strong> and <strong>Boost Your Business.</strong><br />
<img class="size-thumbnail wp-image-70798 aligncenter" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2019/03/advertise-with-us-Google-Search-Mozilla-Firefox-2019-03-02-17.44.06-Custom.jpg?resize=150%2C144&#038;ssl=1" alt="" width="150" height="144" data-recalc-dims="1" />Every advertisement includes <strong>Social Media Postings</strong>. Pricing listed under <strong>About</strong> page, then Inquire:  HughE@PhillyChitChat (dot) com<br />
<a href="https://blog.feedspot.com/philadelphia_lifestyle_blogs/?fbclid=IwAR1yjn42OEdkoCbeCRUW_mABGQNVvD37BbcqN6Hg7_suM_F9yeTsNUvdSH4">Philly Chit Chat has been designated as the #2 most influential Lifestyle Blog in Philadelphia</a> in 2019 &amp; 2020 by Feedly.com</p>
</div>
		</li>
<li id="categories-2" class="widget widget_categories"><h2 class="widgettitle">Categories</h2>
		<ul>
				<li class="cat-item cat-item-2212"><a href="https://phillychitchat.com/category/philadelphia/">Philadelphia</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://phillychitchat.com/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</li>
<li id="feedburner-email-subscription-2" class="widget feedburner-email-subscription"><h2 class="widgettitle">Subscribe</h2>
<form class="fes fes-default" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open( 'http://feedburner.google.com/fb/a/mailverify?uri=PhillyChitChat', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" ><div class="form-group"><label class="sr-only"><span class="screen-reader-text">Email Subscription</span></label><input class="form-control search-field" type="text" value="Enter Your Email" onfocus="if(this.value=='Enter Your Email')this.value='';" onblur="if(this.value=='')this.value='Enter Your Email'" name="email" /></div><button type="submit" class="btn btn-default btn-submit">Submit</button><input type="hidden" value="PhillyChitChat" name="uri" /><input type="hidden" name="loc" value="en_US" /></form></li>
				</ul>
			</div>
				<div class="col-md-6">
			<div class="blog-post blog-post-single clearfix">
				<article id="post-75918" class="post-75918 post type-post status-publish format-standard hentry category-uncategorized tag-aversa-pr tag-chinese-food-center-city tag-client tag-dim-sum-house tag-media-and-influencer-night">
							<div class="post-content-wrapper">

								<div class="post-content">
																		
									<div class="post-categories"><a href="https://phillychitchat.com/category/uncategorized/" rel="category tag">Uncategorized</a></div>

									
									<h1 class="entry-title post-header-title">Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food</h1>
									<div class="post-info clearfix">
										<span>February 20, 2020</span>
																														<span>by HughE Dillon</span>
										
																														<span class="comments-count"><a href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/#respond">Leave a comment</a></span>
										
										
									</div>
																																																								<div class="entry-content">
										
<div data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="75919" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7102-small-custom/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582054978&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.04&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7102-Small-Custom" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?w=810&#038;ssl=1" alt="" class="wp-image-75919" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?w=550&amp;ssl=1 550w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7102-Small-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></div>



<p>Today: <a href="https://menupages.com/dim-sum-house/3939-chestnut-st-philadelphia">Dim Sum House</a>&#8216;s Grand Opening in Rittenhouse With Free Food. <strong>Jane Guo </strong>(above) and Jackson Fu announce the grand opening of Dim Sum House by Jane G’s TODAY February 20, 2020, at 1930 Chestnut Street, at 11:30am. The mother-son duo will bring all-day, every-day dim sum in two styles to Rittenhouse Square. On top of Shanghai and Cantonese dim sum, Dim Sum House in Rittenhouse will also feature dishes from the Jiang Nan region of China including noodles, entrees, fried rice and soups.</p>



<div data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="75920" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7067-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582053875&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7067-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?w=810&#038;ssl=1" alt="" class="wp-image-75920" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7067-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></div>



<p>For its grand opening, from 12:00pm to 2:00pm, dine-in guests will  celebrate with a complimentary order of <strong>Scallion Pancakes</strong> per table.  From 5:00pm to 7:00pm, dine-in guests will enjoy a complimentary order  of <strong>Dan Dan Noodles</strong> per table. </p>



<figure class="wp-block-gallery columns-3 is-cropped"><ul data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img data-attachment-id="75922" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7062-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;6.3&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582053251&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;34&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7062-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75922" data-link="https://phillychitchat.com/?attachment_id=75922" class="wp-image-75922" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7062-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75923" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7072-custom/" data-orig-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582054025&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7072-Custom" data-image-description="" data-medium-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75923" data-link="https://phillychitchat.com/?attachment_id=75923" class="wp-image-75923" srcset="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?w=550&amp;ssl=1 550w, https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7072-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75924" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7115-small-custom/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055123&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;38&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.05&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7115-Small-Custom" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75924" data-link="https://phillychitchat.com/?attachment_id=75924" class="wp-image-75924" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?w=550&amp;ssl=1 550w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7115-Small-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75925" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7053-custom/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582051463&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7053-Custom" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75925" data-full-url="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?fit=550%2C367&amp;ssl=1" data-link="https://phillychitchat.com/?attachment_id=75925" class="wp-image-75925" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?w=550&amp;ssl=1 550w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7053-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li></ul></figure>



<p> Dim Sum House will test a brand-new ordering system at the dining room  tables. With each seating, guests will be able to place their orders for  dim sum favorites on a checklist they can hand off and update with  their server as their experience progresses. This is especially useful  for large groups. Look for this system to debut in University City later  this winter. </p>



<figure class="wp-block-image size-large"><img data-attachment-id="75926" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7088-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582054570&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;55&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7088-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?w=810&#038;ssl=1" alt="" class="wp-image-75926" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7088-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure>



<figure class="wp-block-image size-large"><img data-attachment-id="75938" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7048-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582051078&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;180&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.02&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7048-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?w=810&#038;ssl=1" alt="" class="wp-image-75938" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7048-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /><figcaption> Dim Sum House in Rittenhouse will launch seven day a week happy hour  later this winter. For lunch specials, guests can enjoy a $13 lunch  featuring a choice of soup (Hot &amp; Sour or Wonton) with a choice of  one of 20 entrees, and a side of rice (White, Brown, and Fried). </figcaption></figure>



<figure class="wp-block-gallery columns-3 is-cropped"><ul data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img data-attachment-id="75927" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7161-custom/" data-orig-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055745&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7161-Custom" data-image-description="" data-medium-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75927" data-link="https://phillychitchat.com/?attachment_id=75927" class="wp-image-75927" srcset="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?w=550&amp;ssl=1 550w, https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7161-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75930" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7157-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055672&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7157-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75930" data-link="https://phillychitchat.com/?attachment_id=75930" class="wp-image-75930" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7157-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75931" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7058-small-custom-1/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582052510&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;32&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7058-Small-Custom-1" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?w=810&#038;ssl=1" alt="" data-id="75931" data-link="https://phillychitchat.com/?attachment_id=75931" class="wp-image-75931" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7058-Small-Custom-1.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75932" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7106-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055015&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.05&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7106-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75932" data-full-url="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?fit=550%2C367&amp;ssl=1" data-link="https://phillychitchat.com/?attachment_id=75932" class="wp-image-75932" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7106-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li></ul></figure>



<figure class="wp-block-gallery columns-2 is-cropped"><ul data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img data-attachment-id="75934" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7144-small-custom/" data-orig-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055385&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.1&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7144-Small-Custom" data-image-description="" data-medium-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75934" data-link="https://phillychitchat.com/?attachment_id=75934" class="wp-image-75934" srcset="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?w=550&amp;ssl=1 550w, https://i1.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7144-Small-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li><li class="blocks-gallery-item"><figure><img data-attachment-id="75935" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7156-small-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055579&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.1&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7156-Small-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75935" data-full-url="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-link="https://phillychitchat.com/?attachment_id=75935" class="wp-image-75935" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7156-Small-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li></ul></figure>



<figure class="wp-block-image size-large"><img data-attachment-id="75936" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7128-small/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?fit=720%2C480&amp;ssl=1" data-orig-size="720,480" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;7.1&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582055242&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;28&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.066666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7128-Small" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?fit=720%2C480&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?w=810&#038;ssl=1" alt="" class="wp-image-75936" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?w=720&amp;ssl=1 720w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7128-Small.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 720px) 100vw, 720px" data-recalc-dims="1" /></figure>



<figure class="wp-block-gallery columns-1 is-cropped"><ul data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/"}' class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img data-attachment-id="75921" data-permalink="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/hjd_7056-small-custom/" data-orig-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-orig-size="550,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D750&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582052469&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;62&quot;,&quot;iso&quot;:&quot;1600&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="HJD_7056-Small-Custom" data-image-description="" data-medium-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?w=810&#038;ssl=1" alt="" data-id="75921" data-full-url="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?fit=550%2C367&amp;ssl=1" data-link="https://phillychitchat.com/?attachment_id=75921" class="wp-image-75921" srcset="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?w=550&amp;ssl=1 550w, https://i2.wp.com/phillychitchat.com/wp-content/uploads/2020/02/HJD_7056-Small-Custom.jpg?resize=300%2C200&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></figure></li></ul><figcaption class="blocks-gallery-caption"> Opening services for Dim Sum House in Rittenhouse include lunch, dinner,  and bar service. Opening hours are Mondays through Thursdays from  11:30am to 10:00pm, Fridays from 11:30am to 11:00pm, Saturdays from  11:00am to 11:00pm, and Sundays from 11:00am to 10:00pm. Lunch hours run  11:30am to 3:00pm weekdays, and 11:00am to 3:00pm on weekends. The  kitchen closes at 9:45pm on weekdays and 10:45pm on weekends. Delivery  service and catering currently exist in University City. They will  launch in the new Rittenhouse location in March, 2020. Dim Sum House in  Rittenhouse is fully handicap accessible. </figcaption></figure>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-75918" class="share-twitter sd-button share-icon" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-75918" class="share-facebook sd-button share-icon" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-144387658-75918-5e4ecabb9d032' data-src='https://widgets.wp.com/likes/#blog_id=144387658&amp;post_id=75918&amp;origin=phillychitchat.com&amp;obj_id=144387658-75918-5e4ecabb9d032' data-name='like-post-frame-144387658-75918-5e4ecabb9d032'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>																			</div><!-- .entry-content -->


																		</div>

							</div>

				
				<span class="tags">
					<a href="https://phillychitchat.com/tag/aversa-pr/" rel="tag">aversa pr</a><a href="https://phillychitchat.com/tag/chinese-food-center-city/" rel="tag">Chinese Food Center City</a><a href="https://phillychitchat.com/tag/client/" rel="tag">client</a><a href="https://phillychitchat.com/tag/dim-sum-house/" rel="tag">Dim Sum House</a><a href="https://phillychitchat.com/tag/media-and-influencer-night/" rel="tag">Media and Influencer Night</a>				</span>

				
				
									<div class="post-social-wrapper">
	<div class="post-social-title show-social-share">
		<a><i class="fa fa-share-alt"></i> Share</a>
	</div>
	<div class="post-social">
		<a title="Share this" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" data-title="Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food" class="facebook-share"> <i class="fa fa-facebook"></i></a>
		<a title="Tweet this" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" data-title="Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food" class="twitter-share"> <i class="fa fa-twitter"></i></a>
		<a title="Share with Google Plus" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" data-title="Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food" class="googleplus-share"> <i class="fa fa-google-plus"></i></a>
		<a title="Pin this" href="https://phillychitchat.com/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/" data-title="Today: Dim Sum House&#8217;s Grand Opening in Rittenhouse With Free Food" data-image="" class="pinterest-share"> <i class="fa fa-pinterest"></i></a>
	</div>
	<div class="clear"></div>
</div>				


				</article>


			</div>

										
				<nav role="navigation" id="nav-below" class="navigation-post navigation-paging">
	
		<div class="container-fluid">
	<div class="row">
		<div class="col-md-12">
		<div class="nav-previous"><a href="https://phillychitchat.com/2020/02/19/createxchange-hosts-pauline-brown-with-daymond-john-in-the-wings/" rel="prev">Previous post</a></div>		
				</div>
	</div>
	</div>
	
	</nav><!-- #nav-below -->
	
						<div class="blog-post-related clearfix"><h5>You may also like</h5>		<div class="blog-post-related-item">
		<a href="https://phillychitchat.com/2020/01/31/top-chef-quickfire-opens-at-the-concourse-at-comcast-center/" class="blog-post-related-image"><img src="" alt="Top Chef Quickfire Opens  at The Concourse at Comcast Center"/></a>
		<a href="https://phillychitchat.com/2020/01/31/top-chef-quickfire-opens-at-the-concourse-at-comcast-center/" class="blog-post-related-title">Top Chef Quickfire Opens  at The Concourse at Comcast Center</a>
		<div class="blog-post-related-date">January 31, 2020</div>
		</div>
				<div class="blog-post-related-item">
		<a href="https://phillychitchat.com/2020/01/24/wonderspaces-is-a-wonderful-way-to-see-art-opens-today/" class="blog-post-related-image"><img src="" alt="Wonderspaces Is A Wonderful Way to See Art &#8211; Opens Today"/></a>
		<a href="https://phillychitchat.com/2020/01/24/wonderspaces-is-a-wonderful-way-to-see-art-opens-today/" class="blog-post-related-title">Wonderspaces Is A Wonderful Way to See Art &#8211; Opens Today</a>
		<div class="blog-post-related-date">January 24, 2020</div>
		</div>
				<div class="blog-post-related-item">
		<a href="https://phillychitchat.com/2020/01/23/inbox-barbara-corcoran-endorses-local-real-estate-agent-maria-quattrone/" class="blog-post-related-image"><img src="" alt="InBox: Barbara Corcoran endorses Local Real Estate Agent Maria Quattrone"/></a>
		<a href="https://phillychitchat.com/2020/01/23/inbox-barbara-corcoran-endorses-local-real-estate-agent-maria-quattrone/" class="blog-post-related-title">InBox: Barbara Corcoran endorses Local Real Estate Agent Maria Quattrone</a>
		<div class="blog-post-related-date">January 23, 2020</div>
		</div>
		</div>			
				<div id="comments" class="comments-area">

	
					<div class="comments-form-wrapper" id="comments-form-wrapper">
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/20/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&#038;postid=75918&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.2.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=af1339208fc83ba08359d6a9d04febe1de0da557#parent=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

				</div>
				
	
	

</div><!-- #comments -->



		</div>
				<div class="col-md-3 main-sidebar sidebar">
		<ul id="main-sidebar">
		  <li id="text-2" class="widget widget_text"><h2 class="widgettitle">About Philly Chit Chat</h2>
			<div class="textwidget"><p><img class="alignnone size-thumbnail wp-image-71008" src="https://i2.wp.com/phillychitchat.com/wp-content/uploads/2019/03/Headshot.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><br />
HughE Dillon, Publicity Photographer for media placements . Prices, Info &amp; Contact in ABOUT Tab at the top.</p>
</div>
		</li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><h2 class="widgettitle">Follow On Social Media</h2>
<div class="textwidget custom-html-widget"><div class="social-icons-wrapper"><a href="https://www.facebook.com/PhillyChitChat/" target="_blank" class="a-facebook" title="Facebook" rel="noopener noreferrer"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/HughE_Dillon" target="_blank" class="a-twitter" title="Twitter" rel="noopener noreferrer"><i class="fa fa-twitter"></i></a><a href="https://plus.google.com/+HughEDillon" target="_blank" class="a-google-plus" title="Google+" rel="noopener noreferrer"><i class="fa fa-google-plus"></i></a><a href="https://www.instagram.com/phillychitchat/" target="_blank" class="a-instagram" title="Instagram" rel="noopener noreferrer"><i class="fa fa-instagram"></i></a><a href="https://www.periscope.tv/iphillychitchat" target="_blank" class="a-periscope" title="Periscope" rel="noopener noreferrer"><i class="fa fa-map-marker"></i></a></div></div></li>
<li id="media_image-3" class="widget widget_media_image"><h2 class="widgettitle">Louie Louie &#8211; French Inspired Restaurant</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 210px" class="wp-caption alignnone"><a href="https://www.louielouie.restaurant/"><img width="200" height="200" src="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?fit=200%2C200&amp;ssl=1" class="image wp-image-71370  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?w=200&amp;ssl=1 200w, https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="71370" data-permalink="https://phillychitchat.com/ll_chitchat-banner-32619-custom/" data-orig-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?fit=200%2C200&amp;ssl=1" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LL_ChitChat banner 32619 (Custom)" data-image-description="" data-medium-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?fit=200%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/phillychitchat.com/wp-content/uploads/2019/03/LL_ChitChat-banner-32619-Custom.png?fit=200%2C200&amp;ssl=1" /></a><p class="wp-caption-text">3611 WALNUT STREET PHILADELPHIA, PA 19104 (267) 805-8585 </p></div></li>
<li id="twitter-follow-2" class="widget widget_twitter-follow"><h2 class="widgettitle">#SaveTheDatePHL</h2>
<div class="twitter-follow"><a href="https://twitter.com/intent/follow?screen_name=HughE_Dillon" class="twitter-follow-button" data-show-screen-name="false">Follow @HughE_Dillon</a></div></li>
<li id="media_image-11" class="widget widget_media_image"><h2 class="widgettitle">Escape to the Riviera between February 29 &#8211; March 8, 2020 at the Philadelphia Flower Show.</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 213px" class="wp-caption alignnone"><a href="https://theflowershow.com/tickets/"><img width="203" height="300" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Screenshot_2020-02-12-PHS-Flower-Show-Gala-Google-Search1-e1581492098134.jpg?fit=203%2C300&amp;ssl=1" class="image wp-image-75829  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" data-attachment-id="75829" data-permalink="https://phillychitchat.com/screenshot_2020-02-12-phs-flower-show-gala-google-search1/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Screenshot_2020-02-12-PHS-Flower-Show-Gala-Google-Search1-e1581492098134.jpg?fit=250%2C369&amp;ssl=1" data-orig-size="250,369" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-02-12 PHS Flower Show Gala &#8211; Google Search(1)" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Screenshot_2020-02-12-PHS-Flower-Show-Gala-Google-Search1-e1581492098134.jpg?fit=203%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/02/Screenshot_2020-02-12-PHS-Flower-Show-Gala-Google-Search1-e1581492098134.jpg?fit=693%2C1024&amp;ssl=1" /></a><p class="wp-caption-text">The 2020 PHS Philadelphia Flower Show, "Riviera Holiday," invites you to fall in love with your garden all over again. Explore the Mediterranean-inspired gardens with groves of citrus trees and sweet-smelling varieties of geraniums and roses. Embrace your inner romantic at the Flower Show and enhance your visit with the various experiences offered.</p></div></li>
<li id="media_image-7" class="widget widget_media_image"><h2 class="widgettitle">BRAVA Philadelphia! 2020 Gala</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 310px" class="wp-caption alignnone"><a href="https://www.avaopera.org/about-ava/calendar/158/brava-philadelphia-2020-gala/"><img width="300" height="300" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?fit=300%2C300&amp;ssl=1" class="image wp-image-75485  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?w=1582&amp;ssl=1 1582w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?resize=1024%2C1024&amp;ssl=1 1024w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?resize=1536%2C1536&amp;ssl=1 1536w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="75485" data-permalink="https://phillychitchat.com/screenshot_2020-01-22-social-media-promo-hughe-phillychitchat-com-phillychitchat-mail/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?fit=1582%2C1582&amp;ssl=1" data-orig-size="1582,1582" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-01-22 Social Media Promo &#8211; hughe phillychitchat com &#8211; PhillyChitChat Mail" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-22-Social-Media-Promo-hughe-phillychitchat-com-PhillyChitChat-Mail.jpg?fit=810%2C810&amp;ssl=1" /></a><p class="wp-caption-text">Funds raised from each annual Gala benefit the AVA Scholarship Fund, which provides tuition-free training to the world’s most promising opera soloists!</p></div></li>
<li id="text-23" class="widget widget_text"><h2 class="widgettitle">Dancing With The Stars for Character Gala!</h2>
			<div class="textwidget"><div id="attachment_75219" style="width: 210px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-75219" class="size-full wp-image-75219" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/200x200-web-ad.jpg?resize=200%2C200&#038;ssl=1" alt="" width="200" height="200" data-recalc-dims="1" /><p id="caption-attachment-75219" class="wp-caption-text">Dance the night away with CITRS at our first annual Dancing With The Stars for Character Gala! <a href="https://www.citrs.org/dwts">INFO</a></p></div>
</div>
		</li>
<li id="media_image-9" class="widget widget_media_image"><h2 class="widgettitle">Red Ball 3/28/20 at Vie</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 210px" class="wp-caption alignnone"><a href="https://www.redcross.org/local/pennsylvania/eastern-pennsylvania/about-us/news-and-events/events/red-ball.html"><img width="200" height="171" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-29-Red-Ball-2020-hughe-phillychitchat-com-PhillyChitChat-Mail-Custom.png?fit=200%2C171&amp;ssl=1" class="image wp-image-75768  attachment-full size-full" alt="Red Ball 2020" style="max-width: 100%; height: auto;" data-attachment-id="75768" data-permalink="https://phillychitchat.com/screenshot_2020-01-29-red-ball-2020-hughe-phillychitchat-com-phillychitchat-mail-custom/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-29-Red-Ball-2020-hughe-phillychitchat-com-PhillyChitChat-Mail-Custom.png?fit=200%2C171&amp;ssl=1" data-orig-size="200,171" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-01-29 Red Ball, 2020 &#8211; hughe phillychitchat com &#8211; PhillyChitChat Mail (Custom)" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-29-Red-Ball-2020-hughe-phillychitchat-com-PhillyChitChat-Mail-Custom.png?fit=200%2C171&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-29-Red-Ball-2020-hughe-phillychitchat-com-PhillyChitChat-Mail-Custom.png?fit=200%2C171&amp;ssl=1" /></a><p class="wp-caption-text">Red Ball is the American Red Cross’ largest fundraiser in the Philadelphia area and 2020 marks the 20th anniversary! Red Ball is a reception style black-tie gala – it’s elegance without the long sit-down dinner and program! All funds raised support the Red Cross House, the center for disaster recovery in Philadelphia.</p></div></li>
<li id="media_image-6" class="widget widget_media_image"><h2 class="widgettitle">The Junior League of Philadelphia, Inc.’s 2020 Spring Gala</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://www.jlphiladelphia.org/springgala2020/"><img width="300" height="213" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?fit=300%2C213&amp;ssl=1" class="image wp-image-75480  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?w=1340&amp;ssl=1 1340w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?resize=300%2C213&amp;ssl=1 300w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?resize=1024%2C726&amp;ssl=1 1024w, https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?resize=768%2C544&amp;ssl=1 768w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="75480" data-permalink="https://phillychitchat.com/screenshot_2020-01-21-save-the-date-spring-gala-the-junior-league-of-philadelphia-inc/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?fit=1340%2C950&amp;ssl=1" data-orig-size="1340,950" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-01-21 SAVE THE DATE – SPRING GALA The Junior League of Philadelphia, Inc" data-image-description="" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?fit=300%2C213&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-21-SAVE-THE-DATE-–-SPRING-GALA-The-Junior-League-of-Philadelphia-Inc-.png?fit=810%2C574&amp;ssl=1" /></a></li>
<li id="media_image-8" class="widget widget_media_image"><h2 class="widgettitle">The 16th Annual Sandy Sprint Superhero Run/Walk</h2>
<style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><div style="width: 310px" class="wp-caption alignnone"><a href="http://wesupport.sandyovarian.org/site/TR?fr_id=1120&#038;pg=entry"><img width="300" height="300" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-26-Sandy-Sprint-2020-photo-opportunity-hughe-phillychitchat-com-PhillyChitChat-Mail-e1580032221415.jpg?fit=300%2C300&amp;ssl=1" class="image wp-image-75554  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" data-attachment-id="75554" data-permalink="https://phillychitchat.com/screenshot_2020-01-26-sandy-sprint-2020-photo-opportunity-hughe-phillychitchat-com-phillychitchat-mail/" data-orig-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-26-Sandy-Sprint-2020-photo-opportunity-hughe-phillychitchat-com-PhillyChitChat-Mail-e1580032221415.jpg?fit=225%2C225&amp;ssl=1" data-orig-size="225,225" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="he 16th Annual Sandy Sprint Superhero Run/Walk" data-image-description="&lt;p&gt;he 16th Annual Sandy Sprint Superhero Run/Walk &lt;/p&gt;
" data-medium-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-26-Sandy-Sprint-2020-photo-opportunity-hughe-phillychitchat-com-PhillyChitChat-Mail-e1580032221415.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2020/01/Screenshot_2020-01-26-Sandy-Sprint-2020-photo-opportunity-hughe-phillychitchat-com-PhillyChitChat-Mail-e1580032221415.jpg?fit=810%2C810&amp;ssl=1" /></a><p class="wp-caption-text">The 16th Annual Sandy Sprint Superhero Run/Walk </p></div></li>
<li id="text-16" class="widget widget_text"><h2 class="widgettitle">The Kimmel Center for the Performing Arts</h2>
			<div class="textwidget"><p><img class="size-thumbnail wp-image-70803 aligncenter" src="https://i0.wp.com/phillychitchat.com/wp-content/uploads/2019/03/me-Custom.jpg?resize=150%2C150&#038;ssl=1" alt="" width="150" height="150" data-recalc-dims="1" /><a href="https://www.kimmelcenter.org/">The Kimmel Center for the Performing Arts</a> &#8211; where there&#8217;s always something going on.</p>
</div>
		</li>
		</ul>
		</div>
			</div>
	</div>
</div>




<div class="footer-instagram-wrapper"><h5>Follow us @ Instagram</h5>        <div id="sbi_mod_error" >
            <span>This error message is only visible to WordPress admins</span><br />
            <p><b>Error: No connected account.</b>
            <p>Please go to the Instagram Feed settings page to connect an account.</p>
        </div>
		</div><div class="container-fluid container-fluid-footer">
  <div class="row">
            <footer class="footer-style-mini">
      <div class="container">
      <div class="row">
                    <div class="col-md-12 footer-logo">
            <a class="logo-link" href="https://phillychitchat.com"><img src="http://www.phillychitchat.com/wp-content/uploads/2016/04/logo2-1.png" alt="Philly Chit Chat" /></a>          </div>
                    <div class="col-md-6 footer-menu">
            <div class="menu-main-menu-container"><ul id="menu-main-menu-2" class="footer-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="https://phillychitchat.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://phillychitchat.com/pccbuzz/">#PCCBUZZ</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://phillychitchat.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51874"><a href="http://www.phillychitchat.com/?s">Search</a></li>
</ul></div>          </div>
          <div class="col-md-6 copyright">
               <p style="text-align: center">© 2019 Philly Chit Chat</p>          </div>
                </div>
      </div>
      <a id="top-link" href="#top"></a>
    </footer>

  </div>
</div>

<!--  -->
<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://phillychitchat.com/wp-admin/admin-ajax.php";
</script>
<!-- Your Google Analytics Plugin is missing the tracking ID -->
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/phillychitchat.com\/2020\/02\/20\/today-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food\/":75918};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/phillychitchat.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/modules/wpgroho.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/phillychitchat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/bootstrap.min.js?ver=3.1.1'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/easing.js?ver=1.3'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/select2/select2.min.js?ver=3.5.1'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/owl-carousel/owl.carousel.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/jquery.nanoscroller.min.js?ver=3.4.0'></script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/themes/piemont/js/template.js?ver=1.0'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
window.twttr=(function(w){t=w.twttr||{};t._e=[];t.ready=function(f){t._e.push(f);};return t;}(window));
/* ]]> */
</script>
<script type="text/javascript" id="twitter-wjs" async defer src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/phillychitchat.com\/wp-admin\/admin-ajax.php","nonce":"1dfa28dccc","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/phillychitchat.com\/wp-login.php?redirect_to=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script async="async" type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"font_method":"svg","resized_url":"https:\/\/phillychitchat.com\/wp-content\/uploads\/sb-instagram-feed-images\/","placeholder":"https:\/\/phillychitchat.com\/wp-content\/plugins\/instagram-feed\/img\/placeholder.png"};
/* ]]> */
</script>
<script type='text/javascript' src='https://phillychitchat.com/wp-content/plugins/instagram-feed/js/sb-instagram-2-2.min.js?ver=2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.2/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202008#ver=202008' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&postid=75918&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=af1339208fc83ba08359d6a9d04febe1de0da557#parent=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144387658&postid=75918&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=af1339208fc83ba08359d6a9d04febe1de0da557#parent=https%3A%2F%2Fphillychitchat.com%2F2020%2F02%2F20%2Ftoday-dim-sum-houses-grand-opening-in-rittenhouse-with-free-food%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.2',blog:'144387658',post:'75918',tz:'-5',srv:'phillychitchat.com'} ]);
	_stq.push([ 'clickTrackerInit', '144387658', '75918' ]);
</script>
</body>
</html>